Data Sets / v.Designer

Hallo in die Runde,

ich habe mit der Reportabfrage ein DataSet erstellt und möchten eine vorhandenen Report um dieses DataSet ergänzen.
Sobald ich die 1. Eingabemaske mit Next bestätige erhalt ich folgenden Fehler:

No SNCA.xml configuration could be loaded! Please configure the datasource, in order to load the SCNA.xml from a local verinice client or a verinice.PRO server.

Was muss ich tun?

LG
Andrea

Hallo Frau Sudbrock,

damit der v.Designer Daten aus einer verinice Datenbank laden kann, muss eine Data Source angelegt werden. Nachdem eine Report-Vorlage in verinice geöffnet wurde, wählen Sie auf der linken Seite den Reiter “Data Explorer”. Öffnen Sie die Data Source “verinice” durch Doppelklick. Prüfen Sie danach die Konfiguration der Data Source. Wenn noch keine Data Source existiert, legen Sie eine neue Data Source mit dem Namen “verinice” an. Als Data Source Type wählen Sie “verinice Data Source”.

Wenn Sie verinice.PRO benutzen, tragen Sie in den Feldern “SNCA URL” und “verinice Server URI” Hostnamen/IP-Adresse und Port Ihres verinice.PRO-Servers ein (siehe Screenshot). Testen Sie die Verbindung indem Sie den Button “Test Connection” klicken. Sie sollten die Meldung “Ping succeeded” erhalten. Wenn die Verbindung fehlschlägt, vergleichen Sie bitte noch einmal die URL mit der, die sie in Ihrem verinice-Client eingetragen haben.

Wenn Sie verinice in der Standalone-Version benutzen, müssen Sie zunächst den verinice Client starten. Der verinice Client muss geöffnet bleiben, solange Sie mit dem v.Designer arbeiten. Tragen Sie folgende Werte in die Felder ein:

:information_source: Mehr Informationen erhalten Sie in der v.Designer Kurzanleitung (ist im Ordner des v.Designers enthalten).


MfG
Tatjana Anisow

1 Like

Guten Morgen Frau Anisow,

die Einstellungen sind vorhanden und er Ping ist erfolgreich.
Ich scheine bei dem Data Set Typ “Report-Abfrage” etwas falsch zu machen. Kurzanleitung Seite 4.
Ein ganz neuer eigener Report läßt sich auch nicht erstellen. Fehlermeldung:

Invalid thread access
Plug-in Provider:Eclipse.org
Plug-in Name:BIRT Designer UI
Plug-in ID:org.eclipse.birt.report.designer.ui
Version:3.7.0.v20110602
Error Code:Error.GUIException.invokedBySWTException
Error Message:Invalid thread access

MfG
Andrea Sudbrock

Wenn die Frage schon auf dem Tisch ist… Warum sieht man in den Bildern tlw. Port 8080, während in den Beschreibungen immer von 8800 die Rede ist? Gibt es hier einen Hintergrund dazu?

Hallo,

nach einem kurzen Telefonat konnte der Fehler behoben werden… dieser Eintrag dient also als Information für andere Anwender.

Die Auflösung des Fehlers: Der v.Designer war in einer älteren Version installiert und hat dementsprechend nicht mit der verinice Version übereingestimmt, sodass die Verbindung nicht hergestellt werden konnte.

:information_source: Die Version von verinice und dem v.Designer müssen übereinstimmen.

MfG
Tatjana Anisow

Hallo Member123,

auf den Bildern ist die Standardeinstellung, also jeweils mit dem Port 8080, zu sehen. Das ist ein guter Einwand, den ich gerne weiter gebe. Wir werden die Dokumentation entsprechend anpassen. Vielen Dank für den Hinweis.

MfG
Tatjana Anisow