Installation auf Centos 7 Anleitung 5.5 Apache / Sicherer Zugriff per SSL Forbidden

Hallo,

ich installiere gerade anhand der Anleitung „Installation und Konfiguration von verinice.PRO unter CentOS und RHEL7“ Verinice auf meinem Centos 7 Server.

Via Tomcat und http://verinice:8080/veriniceserver erreiche ich Verinice und auch mein Client kann auf den Server zugreifen.

Jetzt habe ich apache installiert und die verinice.conf heruntergeladen. Ich erhalte allerdings wenn ich

http://verinice

aufrufe. Die MEldung " Forbidden" des Apache Webservers.

Hier mal meine logfiles vpro-appliance-access_log:

CLIENT_IP - - [08/Jan/2020:10:47:46 +0100] „GET / HTTP/1.1“ 403 202
CLIENT_IP - - [08/Jan/2020:10:47:46 +0100] „GET /favicon.ico HTTP/1.1“ 403 213
127.0.0.1 - - [08/Jan/2020:10:48:11 +0100] „GET / HTTP/1.0“ 403 202
CLIENT_IP - - [08/Jan/2020:10:48:37 +0100] „-“ 408 -
CLIENT_IP - - [08/Jan/2020:10:49:33 +0100] „GET / HTTP/1.1“ 403 202
CLIENT_IP - - [08/Jan/2020:10:49:34 +0100] „GET /favicon.ico HTTP/1.1“ 403 213
127.0.0.1 - - [08/Jan/2020:10:51:33 +0100] „GET / HTTP/1.0“ 403 202
127.0.0.1 - - [08/Jan/2020:10:51:42 +0100] „GET / HTTP/1.0“ 403 202
CLIENT_IP - - [08/Jan/2020:10:52:41 +0100] „GET / HTTP/1.1“ 403 202
CLIENT_IP - - [08/Jan/2020:10:52:41 +0100] „GET /favicon.ico HTTP/1.1“ 403 213
CLIENT_IP - - [08/Jan/2020:10:53:32 +0100] „-“ 408 -

vpro-appliance-error_log ist leer.

Wobei CLIENT_IP meine IP des Testrechners ist.

Kann mir bitte jemand sagen was ich falsch mache?

Hier ist meine verinice.conf: (befindet sich im Ordner /etc/httpd/conf.d/vhosts.d/)

LoadModule ssl_module modules/mod_ssl.so
 Listen 443
 ServerName vpro-appliance
 AddType application/x-x509-ca-cert .crt
 AddType application/x-pkcs7-crl    .crl
 SSLPassPhraseDialog  builtin
 SSLSessionCache         shmcb:/var/cache/mod_ssl/scache(512000)
 SSLSessionCacheTimeout  300
 SSLRandomSeed startup file:/dev/urandom  256
 SSLRandomSeed connect builtin
 SSLCryptoDevice builtin
 SSLCipherSuite ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA:AES256-SHA:AES:CAMELLIA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK:!aECDH:!EDH-DSS-DES-CBC3-SHA:!EDH-RSA-DES-CBC3-SHA:!KRB5-DES-CBC3-SHA
 SSLHonorCipherOrder     on
 ServerSignature off
 ServerTokens Prod
 RewriteEngine on

 SetEnvIf User-Agent ".*MSIE.*" \
          nokeepalive ssl-unclean-shutdown \
          downgrade-1.0 force-response-1.0

<VirtualHost *:80>
     ServerAdmin webmaster@vpro-appliance
     DocumentRoot /var/www/html/
     Options -Indexes
     SSLCipherSuite +HIGH:+MEDIUM:!ADH
     SSLProtocol all -SSLv2 -SSLv3
     RewriteEngine on
     RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK|PUT|GET|POST|OPTIONS|DELETE|HEAD)
     RewriteRule .* - [F,L]
     ServerName verinice
     ErrorLog logs/vpro-appliance-error_log
     CustomLog logs/vpro-appliance-access_log common

    ProxyRequests OFF
     <Proxy *>
       Order deny,allow
        Allow from all
   </Proxy>
        RedirectMatch ^/$ /veriniceserver/
        RedirectMatch ^/veriniceserver$ /veriniceserver/
        ProxyPass /veriniceserver/ http://localhost:8080/veriniceserver/ connectiontimeout=3600 timeout=3600
        ProxyPassReverse /veriniceserver/ http://localhost:8080/veriniceserver/
</VirtualHost>

Vielen Dank für die Hilfe!

Viele Grüße
Alex

Ich habe jetzt Nginx anstatt Apache genutzt, da ich mit Nginx mehr (und bessere) Erfahrung als mit Apache habe.

Folgende Konfiguration (unter /etc/conf.d/verinice.conf) funktioniert bei mir:

server {
listen 80;
server_name verinice;

location / {

    client_max_body_size 100m;
    client_body_buffer_size 300m;
    proxy_cache off;
    proxy_buffers                   32 16k;
    proxy_busy_buffers_size         64k;
    proxy_set_header   X-Forwarded-For $remote_addr;
    proxy_set_header   Host $http_host;
    proxy_pass   "http://verinice:8080";

    }   error_page   500 502 503 504  /50x.html;
location = /50x.html {
    root   /usr/share/nginx/html;
}

Der Client startet und ich kann bisher alle Funktionen nutzen!

Viele Grüße
Alex