v.Designer Login auf verinice.PRO-Server

Hallo verinice-Team / verinice-Nutzer,
wenn ich im v.Designer auf ein Data Set zugreifen möchte erscheinen, je nach Report, mehrere Login-Fenster übereinander.
In keines kann ich Login-Daten eingeben.
Alle Login-Fenster melden „Keine Rückmeldung“.

D.h.:

  • Die Konfiguration der Data Source „verinice“ ist korrekt.
  • Ein Zugriff auf der verinice.PRO-Server ist erfolgreich.
  • Der Zugriffsschutz auf die Daten reagiert richtig.
  • Eine Legitimierung durch die Abfrage der Login-Daten erfolgt.

Wie kann nun ein bewuster Login aus dem vDesigner auf einen verinice.PRO-Server erfolgen, ohne das sich der vDesigner „aufhängt“?

Gruß
G. Winkler

1 Like

Das Problem tritt immer dann auf, wenn nach dem Start des v.Designers in einem Report zuerst ein vorhandenes Data-Set geöffnet wird. Die Lösung ist zuerst nach dem Start den Wizard zu Öffnen, mit dem man ein neues Data-Set anlegt:

Outline -> Report -> Data Sets -> Context Menu -> New Data Set

Im Wizard wählen sie die Data-Source, die mit dem verinice.PRO-Server verbunden ist und klicken auf Next >. Jetzt erscheint ein einzelner Log-Dialog, der sich normal bedienen lässt. Nach Eingabe von Name und Password und dem Schließen des Login-Dialogs kann der Wizard zum Anlegen eines neuen Data-Sets durch Klick auf Cancel geschlossen werden.

Danach können auch die vorhandenen Data-Sets, die dieselbe Data-Source benutzen, geöffnet werden.

Hallo Herr Murygin,

danke für die Antwort.

Diesen Workaround habe ich auch schon entdeckt.

Professioneller wäre natürlich eine Login-Funktion in vDesigner.

Gruß
G. Winkler