Verinice 1.17.0.full startet nicht (Win 7 - 32 Bit)


#1

Moin moin,

leider startet unter Windows 7 (32Bit) verinice in der Version 1.17.0.full nicht. Es kommt immer eine Fehlermeldung, dass die JVM nicht gestartet werden konnte:

“Failed to create the Java Virtual Machine.”

Im Logfile findet sich hierzu folgende NoClassDefFound-Exception:

!SESSION 2018-12-17 11:05:35.513 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_161
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=de_DE
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2018-12-17 11:05:47.541
!MESSAGE Anwendungsfehler
!STACK 1
java.lang.NoClassDefFoundError: sun/security/pkcs11/SunPKCS11
	at sernet.gs.ui.rcp.main.Activator.checkPKCS11Support(Activator.java:375)
	at sernet.gs.ui.rcp.main.Activator.startApplication(Activator.java:226)
	at sernet.gs.ui.rcp.main.Application.start(Application.java:43)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
Caused by: java.lang.ClassNotFoundException: sun.security.pkcs11.SunPKCS11 cannot be found by sernet.gs.ui.rcp.main_1.3.0.201811081537
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:484)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 15 more

Um überhaupt soweit zu kommen habe ich manuell den -vm Switch in der verinice.ini eingetragen:

-vm
[VERINICE_HOME]\jre\bin\

Wäre schön, wenn die Software auch unter Windows 7 mit 32 Bit laufen würde. Unter Linux mit 64 Bit scheint alles soweit zu funktionieren.

Mit freundlichen Grüßen,

Daniel K.


#2

Bitte versuchen Sie auf dem betroffenen System, verinice im Auslieferungszustand neu zu starten. Benennen Sie dafür den Ordner <USER_HOME>/verinice/workspace um in workspace.bak.

Starten Sie danach den Client neu.


#3

Es handelt sich um eine frisch entpackte Version von verinice (verinice-windows-x86.zip). Ich habe aber auch mal den workspace-Ordner gelöscht ohne Unterschied.

Die Java-Fehlermeldung bleibt.


#4

Bitte versuchen Sie in die Datei verinice.ini am Ende der Datei die Zeile

-Dos.arch=x86_64

einzutragen. Starten Sie danach verinice neu.

Update (19.12.2018, 11:53 Uhr):
Der Parameter wird zum Starten nicht benötigt (siehe übernächste Antwort).


#5

Keine Verbesserung, gleiche Fehlermeldung im Logfile.


#6

Ich habe verinice-1.17.0 eben erneut auf einem Windows 7 32-Bit System getestet. Auch ich musste die verinice.ini anpassen und die den Parameter -vm vor dem Parameter -data hinzufügen:

-vm
jre\bin\java
-data
@user.home/verinice/workspace

Danach startet verinice auf dem System. Andere Parameter mussten nicht hinzugefügt werden.

Getestet habe ich eine VirtualBox Image, das Microsoft zum testen bereitstellt: Free Virtual Machines from IE8 to MS Edge - Microsoft Edge Development. In diesem Image enthalten ist Windows 7 Enterprise, Service Pack 1.


#7

Bei mir handelt es sich um einen “echten” Rechner mit Windows 7 Professional mit Service Pack 1.

Aber die Fehlermeldung deutet für mich daraufhin, dass beim JRE etwas mit SSL-Verbindungen und/oder Zertifikaten nicht funktioniert. Der Rechner hängt zudem hinter einem Proxy, dass sollte aber keinen NoClassDefFoundError erzeugen.


#8

Hallo in die Runde,
ich habe die gleiche Fehlermeldung. Ich habe es auf Windows 7 und Windows 10 getestet. Ich bekomme es nicht zum Laufen.
Mit freundlichen Grüßen


#9

Wir können das besagte Verhalten leider auf keinem unserer Systeme nachstellen.
Um Probleme in der Konfiguration bzw. den Einstellungen auf Ihrem System auszuschließen, sende Sie uns zur weiteren Untersuchung bitte die Logfiles (siehe Logging von Fehlermeldungen, Log-Files) an verinice@sernet.de mit kurzem Verweis auf diesen Betrag.
Wir hoffen auf ihr Verständnis, dass die Lösung angesichts des Jahreswechsels sicher erst im Januar erfolgen wird.


#10

Wir können das besagte Verhalten wie bereits zuvor erwähnt leider auf keinem unserer Systeme nachstellen.
Um Probleme in der Konfiguration bzw. den Einstellungen auf Ihrem System auszuschließen, sende Sie uns zur weiteren Untersuchung bitte die Logfiles (siehe Logging von Fehlermeldungen, Log-Files) an verinice@sernet.de mit kurzem Verweis auf diesen Betrag.
Wir hoffen auf ihr Verständnis, dass die Lösung angesichts des Jahreswechsels sicher erst im Januar erfolgen wird.


#11

Das Problem von @Hamsterbau wurde mittlerweise im E-Mail-Dialog geklärt.
Es wurde wie in Kommentar Nr. 6 beschrieben der Parameter -vm in die verinice.ini eingefügt.
Außerdem wurde (ebenfalls in der verinice.ini) der maximal zu verwendende Speicher auf 1GB reduziert (-Xmx1g statt -Xmx4g), da es unter 32-Bit-Windows u.U nicht möglich ist, die standardmäßig konfigurierten 4GB zu verwenden.