Client: Allgemeiner Fehler "InvalidClassException"

Verhalten: Fehlermeldung Client-Logfile verinice-client.log:

Could not deserialize result from HTTP invoker remote service [http://veriniceserver:8080/veriniceserver/service/commandServiceHttpInvoker];
nested exception is java.io.InvalidClassException: sernet.verinice.model.common.CnATreeElement;
local class incompatible: stream classdesc serialVersionUID = 2727068555935487761, local class serialVersionUID = 7324625158475666139

Lösungsansatz: Die Fehlermeldung deutet darauf hin, dass ein Client verwendet wird, dessen Versionsnummer ungleich der des eingesetzten Servers ist. Es muss die gleiche Client-Version installiert sein wie die verinice.PRO Version auf dem Server.

Hallo murygin,

habe folgenden Fehler:
Fehler beim Starten der Anwendung.
Could not deserialize result from HTTP invoker remote service [http://svlisms01.lrasbk.de:8080/veriniceserver/service/commandServiceHttpInvoker
]; nested exception is java.io.InvalidClassException: sernet.hui.common.connect.Entity; local class incompatible: stream classdesc serialVersionUID = 7763051508118949848, local class serialVersionUID = 2731330122501440976

Habe den Server auf 1.22.1 aktualisiert, kann mich aber nicht mit der Client Version 1.22 verbinden.
Mit der Version 1.20 geht es!? Aber die Server-Pakete sind aktualisiert!

PIO78

Hallo,

wenn auf dem Server verinice 1.22.1 installiert ist, dann muss der Client in Version 1.22.1 verwendet werden. Die Client Version 1.22 bzw. 1.22.0 ist nicht kompatibel mit der Server-Version 1.22.1.

Viele Grüße, Daniel Murygin

Hi,
aber ich kann mich mit der Version 1.20 noch anmelden.
Das sind die installierten Server-Pakete:

Kann mich natürlich mit der Version 1.22 anmelden, aber beim Anzeigen der Inhalte kommt der Fehler.
Hab es gerade nochmal probiert.

Hallo,

konnte das Problem mittlerweile behoben werden?
Nach unserem Update auf die Version 1.22.1 zeigt sich der gleiche Fehler.

Nein, soweit ich weiss ist das bei uns nie aufgetreten wenn client & server die gleiche version sind.

EDIT: Ansheinend gab es das doch schonmal bei einem verinice Nutzer und dort wurde gedowngraded auf eine ältere verinice version um das Problem vorerst zu beheben.

Das ist sehr komisch, ich kann da leider nicht weiter helfen glaub ich. Ist denn der Client und der Server ganz sicher 1.22.1?

aber ich kann mich mit der Version 1.20 noch anmelden.

Es schlägt nicht gleich alles fehl bei einem version mismatch, Login sollte eh immer gehen, danach kommt es auf die Änderungen in unserem Code an nehme ich an, manches könnte noch gehen aber anderes halt nicht

Hallo,
ist nicht behoben, bin wieder auf die alte Version zurück.

Hallo @MatthiasK @Pio78
Versuchen Sie bitte noch einmal den Server und den Client auf Version 1.22.2 zu updaten.
Wenn das dann nicht klappt bitte stellen Sie eine Support-Anfrage | verinice.com mit den Logs die die aufgelistet werden und das sieht sich jemand genauer an und unterstützt sie beim Update.
Das Update ist aus Sicherheitsgründen wichtig, und auf einer alten Version zu bleiben um diese Fehler zu umgehen ist nicht ratsam.

Hallo,

Update durchgeführt, Problem jetzt behoben.

DANKE…

1 Like